OSPF Network Types, Virtual Links, Summarization and Authentication MegaLab!!

https://www.dropbox.com/sh/lvjjhe5q6xmtjx9/pcN2mFYARP

OSPF Special

1. Set up OSPF according to their areas. Make sure Loopback interfaces will not send out multicast hellos while still being advertised into OSPF and is advertised into OSPF as a subnet.

2. Configure Router-ID to be x.x.x.x where x is the router number. i.e. R1’s Router-ID will be 1.1.1.1

3. Makes sure Hello Timers are set to 2 seconds across the board for fast convergence.

4. Area 0, configure it to be OSPF Network non-broadcast. Ensure proper DR setup and full adjacency and connectivity. What other was necess

ary to ensure proper adjacencies?

5. Area 24 configure it to be OSPF Network Point-to-point. Ensure full adjacency and connectivity. Can we configure this to be broadcast network?

6. Set up Area 24 as a Totally Stubby Area. Make sure the default route propagated has a cost of 23. Make sure the advertised default from R3 is used by routers in Area 24 as the only default route by changing the cost of the default route.

7. Area 356, first configure it to be a OSPF Network point-to-multipoint broadcast. Ensure proper DR setup and full adjacency and connectivities.

8. Summarize Area 356 Loopback networks at the proper router and make sure it’s propagated throughout the OSPF AS with cost of 356.

9. Add Router 7 onto R6 and set it to Area 67. Then add a virtual link so that R7 knows all routes and the rest of the AS know about R7. Confirm with necessary show commands.

10. Configure EIGRP 1 loopbacks on R7. Redistribute into OSPF with metric 78, type 1. What is R1’smetric to reach EIGRP loopbacks on R7? What would those metrics be if the summary was injected into OSPF as type 2?

11. Staying on R1’s CLI only, add up the metric to reach R7’s loopback interface hop by hop. i.e.

___ Advertised Cost by ASBR

___ Cost to reach ASBR

___ Cost to ABR

___ Other Costs

This metric should match the metric in the routing table. What if EIGRP was redistributed into OSPF as a type-2 metric? What would be the metric in the routing table? What would be the forwarding metric?

11. Summarize EIGRP 1’s loopbacks into OSPF at the appropriate router. Configure Area 67 as a Totally NSSA.

12. Configure MD5 authentication on Virtual Link, Area 0, Area 24 and Area 356. Use passwords: cisco, cisco0, cisco24, cisco356 respectively in each area.

13. Add Loop 3 – 172.16.1.0/24 onto R1 and make sure to inject that as a default route with metric of 1234 without redistributing

Advertisements

One comment

  1. R1

    interface Loopback1
    ip address 192.168.1.1 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 0

    interface Loopback2
    ip address 192.168.1.129 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 0

    interface Loopback3
    ip address 172.16.1.1 255.255.255.0
    ip ospf network point-to-point

    interface Serial1/2
    ip address 10.0.0.1 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco0
    ip ospf hello-interval 2
    ip ospf 1 area 0
    frame-relay map ip 10.0.0.3 103
    frame-relay map ip 10.0.0.2 102
    frame-relay interface-dlci 102
    frame-relay interface-dlci 103

    router ospf 1
    router-id 1.1.1.1
    log-adjacency-changes detail
    neighbor 10.0.0.2 priority 2
    neighbor 10.0.0.3 priority 3
    default-information originate always metric 1234 metric-type 1

    ________________

    R2

    interface Serial1/0
    ip address 10.0.24.2 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco24
    ip ospf network point-to-point
    ip ospf hello-interval 2
    ip ospf flood-reduction
    ip ospf 1 area 24
    frame-relay map ip 10.0.24.4 204 broadcast

    interface Serial1/2
    ip address 10.0.0.2 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco0
    ip ospf hello-interval 2
    ip ospf 1 area 0
    serial restart-delay 0
    frame-relay map ip 10.0.0.3 203
    frame-relay map ip 10.0.0.1 201
    frame-relay interface-dlci 201
    frame-relay interface-dlci 203

    router ospf 1
    router-id 2.2.2.2
    log-adjacency-changes detail
    area 24 stub no-summary
    area 24 default-cost 32
    neighbor 10.0.0.3 priority 3
    ________________

    R3

    interface Serial1/0
    no ip address
    encapsulation frame-relay

    interface Serial1/0.1 multipoint
    ip address 10.0.56.3 255.255.255.0
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco356
    ip ospf network point-to-multipoint
    ip ospf hello-interval 2
    ip ospf 1 area 356
    frame-relay map ip 10.0.56.6 306 broadcast
    frame-relay map ip 10.0.56.5 305 broadcast

    interface Serial1/1
    ip address 10.0.34.3 255.255.255.0
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco24
    ip ospf network point-to-point
    ip ospf hello-interval 2
    ip ospf 1 area 24

    interface Serial1/3
    ip address 10.0.0.3 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco0
    ip ospf network non-broadcast
    ip ospf hello-interval 2
    ip ospf 1 area 0
    frame-relay map ip 10.0.0.1 301
    frame-relay map ip 10.0.0.2 302

    router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes detail
    area 24 stub no-summary
    area 24 default-cost 10
    area 356 range 192.168.128.0 255.255.192.0
    area 356 virtual-link 6.6.6.6 hello-interval 2 authentication message-digest
    area 356 virtual-link 6.6.6.6 message-digest-key 1 md5 cisco
    ________________
    R4

    interface Loopback1
    ip address 192.168.40.1 255.255.255.128
    ip ospf network point-to-point

    interface Loopback2
    ip address 192.168.40.129 255.255.255.128
    ip ospf network point-to-point

    interface Serial1/0
    ip address 10.0.24.4 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco24
    ip ospf network point-to-point
    ip ospf hello-interval 2
    ip ospf 1 area 24
    frame-relay map ip 10.0.24.2 402 broadcast

    interface Serial1/1
    ip address 10.0.34.4 255.255.255.0
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco24
    ip ospf hello-interval 2
    ip ospf 1 area 24

    router ospf 1
    router-id 4.4.4.4
    log-adjacency-changes
    area 24 stub

    ________________

    R5

    interface Loopback1
    ip address 192.168.150.1 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 356

    interface Loopback2
    ip address 192.168.150.129 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 356

    interface Serial1/0
    ip address 10.0.56.5 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco356
    ip ospf network point-to-multipoint
    ip ospf hello-interval 2
    ip ospf 1 area 356
    serial restart-delay 0
    frame-relay map ip 10.0.56.3 503 broadcast

    router ospf 1
    router-id 5.5.5.5
    log-adjacency-changes

    ________________

    R6

    interface Loopback1
    ip address 192.168.160.1 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 356

    interface Loopback2
    ip address 192.168.160.129 255.255.255.128
    ip ospf network point-to-point
    ip ospf 1 area 356

    interface FastEthernet0/0
    ip address 10.0.67.6 255.255.255.0
    ip ospf network point-to-point
    ip ospf hello-interval 2
    ip ospf 1 area 67

    interface Serial1/0
    ip address 10.0.56.6 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 cisco356
    ip ospf network point-to-multipoint
    ip ospf hello-interval 2
    ip ospf 1 area 356
    frame-relay map ip 10.0.56.3 603 broadcast

    router ospf 1
    router-id 6.6.6.6
    log-adjacency-changes
    area 67 nssa no-summary
    area 356 virtual-link 3.3.3.3 hello-interval 2 authentication message-digest
    area 356 virtual-link 3.3.3.3 message-digest-key 1 md5 cisco

    ________________

    R7

    interface Loopback1
    ip address 10.0.178.7 255.255.255.0

    interface Loopback2
    ip address 10.0.179.7 255.255.255.0

    interface Loopback3
    ip address 10.0.180.7 255.255.255.0

    interface FastEthernet0/0
    ip address 10.0.67.7 255.255.255.0
    ip ospf network point-to-point
    ip ospf hello-interval 2
    ip ospf 1 area 67

    router eigrp 1
    redistribute ospf 1 metric 1000 0 255 1 1500
    network 10.0.178.0 0.0.0.255
    network 10.0.179.0 0.0.0.255
    network 10.0.180.0 0.0.0.255
    no auto-summary

    router ospf 1
    router-id 7.7.7.7
    log-adjacency-changes
    area 67 nssa no-summary
    summary-address 10.0.160.0 255.255.224.0
    redistribute eigrp 1 metric 78 metric-type 1 subnets

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s